IIJ mio光 ipoe でipv6/ipv4 環境を作ってみた (Cisco 841M & DHCP RA環境 & DS-Lite)

広告

家のNetworkをIPv6化したときに、Cisco 841Mを買った。

以下のページにちょうどやりたい構成があったので、参考にさせてもらった。

ちなみにやりたいことは、ひかりtvをつかっているし、Youtubeとかを快適に見たいので終端までipv6 RAを届かせたい。
v4通信はDS-Liteで高速化したい。(ゲーム用途)

ひかり電話を契約していないのでDHCPv6-PDはなくRAのみ。

ただし、上記Blogの内容そのままだとBVIインターフェイスがなくてbridgeに入ったipv4とCiscoが通信できなかったし
ONUにつながるポートをBridge group に入れるとDS-LiteのTunnelが落ちるので、v4通信が落ちる。
一つのインターフェイスでDS-Liteとipv6パススルーは併用不可な仕様っぽい。っぽい。っぽい。
これではまともな長期利用は望めない。

というわけでいろいろイジって見た。

まず、bridge groupにONUがつながるポートを入れないと、ipv6パススルーができないのでひかりtvが使えないし、
bridge groupにONUがつながるポートを入れると、DS-LiteのTunnelが落ちてv4通信が不通となる。

そこで、WANインターフェイスが2個あるのを利用して、ONUとCiscoの間にHUBを入れた。

[ONU]===[HUB]–[Cisco Gi0/4] ——–[Cisco Vlan1] —[AP, PC, etc….]
      └—[Cisco Gi0/5] — [Cisco BVI1]┘

WAN1として0/4をDS-Lite用インターフェイスにして、
WAN2として0/5をv6 パススルー用にしてBridge groupに入れる。

というわけで以下が基本必要となる部分。

・DS-Lite (v4 private)


ip dhcp pool DHCP
network 192.168.11.0 255.255.255.0
default-router 192.168.11.254
dns-server 8.8.8.8 8.8.4.4
!
interface Tunnel10
description To:MF
ip address 192.0.0.2 255.255.255.248
keepalive 10 3
tunnel source GigabitEthernet0/4
tunnel mode ipv6
tunnel destination 2404:8E00::FEED:100
!
interface Tunnel11
description To:MF
ip address 192.0.1.2 255.255.255.248
keepalive 10 3
tunnel source GigabitEthernet0/4
tunnel mode ipv6
tunnel destination 2404:8E00::FEED:101
!
ip route 0.0.0.0 0.0.0.0 Tunnel10
ip route 0.0.0.0 0.0.0.0 Tunnel11
!
interface GigabitEthernet0/4
description To:MF_AFTR
no ip address
duplex auto
speed auto
ipv6 address autoconfig default
ipv6 enable
ipv6 nd other-config-flag

多分TunnelにKeepaliveを入れる意味はないけど、いろいろ試行した後の残骸ですね・・・。
Tunnel数も1個で十分です。

・v6パススルー


ip cef
ipv6 unicast-routing
ipv6 cef
ipv6 multicast-routing
ip forward-protocol nd
bridge irb
!
interface GigabitEthernet0/5
description To:Ipv6Bridge
no ip address
duplex auto
speed auto
ipv6 address autoconfig
ipv6 enable
ipv6 nd other-config-flag
bridge-group 1
bridge-group 1 input-type-list 200
!
interface Vlan1
description To:CLIENT
no ip address
ipv6 nd other-config-flag
bridge-group 1
!
interface BVI1
ip address 192.168.11.254 255.255.255.0
!
access-list 200 permit 0x86DD 0x0000
!
bridge 1 protocol ieee
bridge 1 route ip

 

次はZone Base Firewallを頑張ってみる予定です・・・。

 

コメントを残す